Требования к хостингу:

Скрипт блога довольно сложен, использует хитрые технологии, а потому и хостинг должен ему соответствовать:

  1. PHP в диапазоне версий 5.2.x ~ 5.4.x

  2. Правильная локаль для выбранного языка блога:

    1. en_EN.CP1250 для англоязычного блога.
    2. ru_RU.CP1251 или rus_RUS.CP1251 в случае русскоязычного блога.
    3. de_DE.CP1252 для блога на немецком языке.

    Подробнее про проверку доступной локали сказано тут.

  3. Модуль mod_rewrite и поддержка .htaccess файлов для работы с модреврайтом.

  4. Модуль Zend Guard.

  5. Таймаут на сервере не менее 30 секунд.
    Речь про таймауты на исполнение скрипта и внешние соединения (это разные таймауты).

  6. Объём оперативной памяти, выделяемой приложению, на уровне 20mb.

  7. Исходящие соединения и РНР mail(); на хосте должны быть разрешены.
    Через них блог общается с внешним миром.

  8. Для рисования всяких графиков и капчи Вам потребуется GD библиотека.

Все вышеназванные требования не являются какими-то выдающимися, и любой платный хостинг за 4-5 уёв в месяц им обычно сразу же удовлетворяет. Собственно говоря, и хостинга рублей за 50 тоже за глаза хватит - например, такого.